Accéder au contenu principal

Comment personnaliser les cases suivant les erreurs ESTERREUR

Vous en avez marre de voir des messages d’erreur dans vos calculs? Il est quand même plus agréable de voir un message clair et bien défini que vous avez configurez vous même.

De quoi parlons nous?

Voici la liste des messages d’erreur que vous pouvez obtenir :

  • #N/A
  • #VALEUR!
  • #REF!
  • #DIV/0!
  • #NOMBRE!
  • #NOM?
  • #NUL

Vous voyez ce que cela donne dans un tableau :

i1

Pour remédier à cela nous allons utiliser la fonction ESTERREUR()

Cette fonction vous retourne VRAI ou FAUX si une case est en erreur :

i2.png

La case B2 a un défaut « #DIV/0! » donc le résultat en B2 avec la formule =ESTERREUR(B2) nous retourne VRAI

La case B3 étant vide la formule nous retourne un FAUX

Personnaliser un message d'erreur par ce que vous voulez

Nous allons encore utiliser la fonction ESTERREUR() et nous allons utiliser un SI également.

On écrit dans la case D2 la formule suivante :

=SI(ESTERREUR(B2); »Erreur dans la division »;B2)

i3.png

Explication de la formule : =SI(ESTERREUR(B2); »Erreur dans la division »;B2)

Si la case B2 a une erreur alors on écrit Erreur dans la division mais s’il n’y a pas d’erreur alors on écrit la valeur de B2

Nous pouvons écrire un autre message comme l’exemple ci dessous :

i4.png

C’est très pratique pour mettre en forme vos tableaux et pour les rendre plus esthétiques.

Laissez nous un commentaire si vous l’utilisez déjà!

Catégories

Facile

Votre commentaire

Entrez vos coordonnées ci-dessous ou cliquez sur une icône pour vous connecter:

Logo WordPress.com

Vous commentez à l’aide de votre compte WordPress.com. Déconnexion /  Changer )

Photo Google

Vous commentez à l’aide de votre compte Google. Déconnexion /  Changer )

Image Twitter

Vous commentez à l’aide de votre compte Twitter. Déconnexion /  Changer )

Photo Facebook

Vous commentez à l’aide de votre compte Facebook. Déconnexion /  Changer )

Connexion à %s

%d blogueurs aiment cette page :